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1. Installation



1.1 Recovery HD



Every Mac has a hidden Recovery HD. To access it, hold down Option as the Mac is starting 
up.



Click Recovery HD. (You can password protect this by using a firmware password.)



Restore From Time Machine - allows you to restore from your backup.
Reinstall OS X - do online install of OS X.
Get Help Online - allows you to search the internet.
Disk Utility - allows you to scan your disks.



Click Reinstall OS X and click Continue.



This requires a fast network connection. Click Continue.



Click Agree.



Click Agree.



You are now ready to install but we won’t do it now. You will need a fast network connection 
because the file is 4GB in size.



Quit the Installer.



Click Get Help Online.



You can use the browser to search for solutions on the internet. Quit the browser.



Click Disk Utility.



This allows you to check your hard disk for issues. Quit Disk Utility.



1.2 Utilities Menu



Click the Utilities menu.



Firmware Password Utility - Disable all keyboard startup shortcuts and displays password 
when you hold down the option key on startup



Network Utility - Check Network connection 



Terminal - Command line interface



Type resetpassword and press return.



You can reset the password for any user here.



1.3 Apple Menu

You can choose which disk to start your Mac up from, Restart or Shut Down.



1.4 Software Update



To update your Mac Software, choose Software Update... from the Apple menu.



Click Update to update your Mac software.



Appendix: OS X 
Mountain Lion Setup



Choose your country and click Continue.



Click Continue.



Click Not Now. Click Continue.



Click Continue.



Click Don’t Use.



Click Skip.



Click Skip.



Click Continue.



Click Agree.



Enter the administrator information and click Continue.



Choose Kuala Lumpur and click Continue.



Click Skip.



Click Skip.



Click Start using your Mac.



Appendix:
Configure Mouse or 

Trackpad



Choose System Preferences... from the Apple menu.



Choose Mouse or Trackpad.



Configure the mouse as shown.



Review the Scroll & Zoom settings. You may wish to change the Scroll direction.



Click Point & Click. Change Tracking Speed to fast and make sure Tap to click is set. Tick 
Three finger drag.



Click More Gestures. Tick App Expose. Close System Preferences when done by clicking the 
Red button.



Appendix:
Mouse Basics



Click the Finder (lower left) to open a Finder window.



Double click the ‘About Downloads’ file to open it.



The file is displayed. Notice that the application name at the top left of the screen has 
changed to Preview. 



Choose Quit Preview from the Preview menu. Notice the name at the top of the screen 
changes back to Finder.



Drag About Stacks to the Desktop. Note that All My Files always shows you all the files that 
belong to you, regardless of their location in the filesystem.



Right-click on About Stacks to show the contextual menu



Right-click on Desktop to change Desktop pattern.



2. User accounts



2.1 User account types



Choose System Preferences from the Apple menu.



Click on Users and Groups.



Click on the little padlock on lower left side.



Put in the admin username and password and click OK to unlock.



Click on the + sign.



Enter a username and password you’d like to use for this account. Normally I do all my work 
in a standard account and only use the administrator account to install software or do other 
administrative task. Better security this way.

Click Create Account. If you see a message onscreen about automatic login, click Keep 
automatic login.



Click Guest User. Tick Allow guests to log in to this computer.



Click +. From the New Account menu you can choose Sharing only. This is for users that can 
only access the Mac over the network. We won’t be creating this account.



Change the menu to Group. Create a new group, teachergroup.



Enable teacher1 in the teachergroup group.



Create the following standard accounts, techer2 (purposely mis-spelled), student1, student2 
and student3.



Add all teachers to the teachergroup group and all students to the studentgroup group.



2.2 Login Items

If you want stuff to start up automatically when you log in, drag it to the Login items.



2.3 Parental Controls



To restrict what a student can do, set Parental controls on the desired account. Here we use 
student3. Click Open Parental Controls...



Tick Use Simple Finder, and tick Limit Applications. Disable all applications except for Safari 
and TextEdit.





For Web, tick allow access to only these websites.



When you do a Fast User switch to student3, this is what you see.



2.4 Home Folder 
contents

Here is what is in your home folder.
Desktop - what is on your desktop.
Documents - default save location for most programs.
Downloads - default location for files downloaded from internet.
Movies - default location for iMovie
Music - default location for GarageBand and iTunes
Pictures - default location for iPhoto
Public - shared by default, put stuff you want to share with other users here.



2.5 Deleting a user 
account



Click the account you want to delete, and click the - button.



Click Delete the home folder. Click Delete User.



2.6 Moving a user 
account



This is the techer2 account. We want to move it to another computer and fix the name.



Change the Desktop Picture and create a few folders so we can see that the changes are 
made after the account has been migrated.



Plug in a thumbdrive. Copy techer2’s home folder to a thumbdrive.



Rename it to teacher2 on the thumbdrive.



Log out of the techer2 account.



Delete the techer2 account.



Choose Delete the home folder and click Delete User.



Plug in the thumbdrive to another computer.



Copy the teacher2 account into the /Users folder.



Click Authenticate.



Enter the admin username and password. Click OK.



Unplug the thumbdrive.



Go to System Preferences, choose Users & Groups.



Click + to create a new account.



Type in Teacher2 and click Create User. The short name must be the same as the name of the 
home directory.



Click Use Existing Folder.



Close System Preferences.



Fast user switch to the Teacher2 account and you should see that everything in that account 
is still there.



2.7 Fast User switching



Go to Login Options and confirm that Fast User switching is on.



You can switch to any user using Fast User Switching.



2.8 Passwords



To change your password, go to your account and click Change Password.



You can set a Firmware password to disable all keyboard startup shortcuts, and to display a 
password field when you hold down option on startup.



A keychain file keeps all your resource passwords, such as email, chat and Wi-Fi passwords. 
You can see the contents of the keychain file by using the Keychain Access program. The 
password to the keychain file is the same as your account password.



Double clicking on any resource will display the details of that resource. Click Show password 
to show the resource password.



You can use a Master password to reset any account password without having to boot into 
the Recovery HD.



2.9 Security 
Preferences

Go to System Preferences -> Security to enable passwords for screen saver and sleep, and to 
disable automatic login.



2.10 Reset Password 
(admin account)

An admin user can reset any user password, however the user’s keychain password is not 
reset.



2.11 Reset password 
(Master Password)

If you enter a password wrong 3 x and the master password is set, you can reset your 
password using a master password, but the keychain password is not reset.



2.12 Keychain

If you see keychain messages after a password reset, delete the keychain to force the system 
to create a fresh keychain file.



3. File Systems



3.1 Partition Schemes

• GUID Partition table

• Master Boot Record

GUID Partition table is the Mac default. Windows machines use Master Boot Record.



3.2 Volume formats

• Mac OS X Extended, Journaled

• Mac OS X Extended, Journaled, Encrypted

• FAT

• ExFAT

• NTFS (Needs Paragon NTFS for read and 
write)

The Mac can create all the volume formats shown except NTFS. The Mac can only read NTFS 
but not write to it.



3.3 Disk Utility



Open Disk Utility. Click on your hard disk. 



Click the info button to see information on your hard disk.



Click the partition.



Click the info button to see information on the partition.



To do this part, you will need a thumbdrive or hard disk that you can erase. Plug the 
thumbdrive into the Mac’s USB port. It will appear in Disk Utility.
WARNING: Do not partition your internal hard disk if you have Boot Camp installed as this will 
disable Boot Camp.



Configure as follows:
Partition Layout: 1 Partition
Name: Backup
Format: Mac OS Extended Journaled
Click Apply.
WARNING: This will delete all data on the thumbdrive.



Click Partition.



The partition has been created on the thumbdrive. The volume name is Backup and the 
format is Mac OS X Extended format.



Click Backup. Click Erase.



You can choose the format you want.



You can also set secure erase options.



3.4 Ejecting a disk

To eject a disk, right click it in the Finder and choose eject, or click the eject icon in the 
Finder window.



3.5 Permissions



Owner, Group and 
Everyone

• Owner - person who creates or copies the 
file

• Group - group defined for the file or folder

• Everyone - everyone who is not the owner 
and not in the group defined

Every file and folder on the Mac has Owner, Group and Everyone permissions.



Unix permissions

• Read

• Write

• Execute

Permissions for each level are Read, Write and Execute.



Create a new folder in your home directory. Call it assignments.



Right click the folder and choose Get Info.



Collapse other sections and expand Sharing & Permissions.



What you see are the standar Unix permissions. 
Owner (admin) - Read & Write
Group (staff) - Read
Everyone (not admin and not staff) - Read



Set everyone to No Access.



If you want to set permissions for more than one group, click +. Add the studentgroup and 
the teachergroup.



We call these additional permissions Access Control Entries (ACE) in an Access Control List 
(ACL) attached to the item. Set studentgroup to read only.



Set teachergroup as Read & Write.



Use Fast User switching to switch to Guest.



Guest has no access to this folder.



Use Fast User Switching to switch to a user in the studentgroup group.



Student can access this folder.



Student cannot write to this folder.



Use Fast User Switching to switch to a user in the teachergroup group.



Teacher can access this folder.



Teacher can write to this folder.



3.6 Reset home 
directory permissions

To set the permissions on the home directory back to factory defaults, start up from the 
Recovery HD, open Terminal, type resetpassword and select the Macintosh HD. Choose the 
account you want and click Reset.



4. Data Management & 
Backup



4.1 Volume Hierarchy

Open a new Finder window and choose Go -> Computer. Open Macintosh HD. Macintosh HD 
is like your C drive. 
Applications -> Program Files
Users -> User files
Library and System is the parts that make the computer work.



4.2 Resource Types



Application Support

• ~/Library/Application Support

• /Library/Application Support

In your home and local Library folder. Stuff that’s required for applications to work. 



Extensions

• Library/Extensions

• /System/Library/Extensions

In Local and System library folders. System Library has Apple’s device drivers. Local Library 
has third party device drivers.



Fonts

• ~/Library/Fonts

• /Library/Fonts

• /System/Library/Fonts

In all Library folders. 



Frameworks

• /Library/Frameworks

• /System/Library/Frameworks

Something like DLLs. System Library has Apple’s frameworks and Library has third party 
frameworks.



Keychains

• ~/Library/Keychains

• /Library/Keychains

• /System/Library/Keychains

In all Library folders. Home Library has your passwords. Local Library has passwords for all 
users. System Library has passwords for the system’s own use.



LaunchDaemons
(before login)

• /Library/LaunchDaemons

• /System/Library/LaunchDaemons

Programs that run in the background, started up before a user logs in. Root privileges. 
System Library has Apple’s LaunchDaemons and Local Library has third party 
LaunchDaemons.



LaunchAgents
(after login)

• ~/Library/LaunchAgents

• /Library/LaunchAgents

• /System/Library/LaunchAgents

Programs that run in the background, started up before a user logs in. User privileges. 
System Library has Apple’s LaunchAgents and Local Library has third party LaunchAgents. 
You can also put it in the user’s own Library.



Logs

• ~/Library/Logs

• /Library/Logs

Shows what’s going on in the system. Access Log files using Console.



Preference Panes

• ~/Library/PreferencePanes

• /Library/PreferencePanes

• /System/Library/PreferencePanes

Appears in System Preferences. Apple’s PreferencePanes are in System Library. Third party 
PreferencePanes are in the other Library folders.



Preferences

• ~/Library/Preferences

• /Library/Preferences

Program settings. Your settings are in your own Library folder. Systemwide settings are in 
Local Library.



Startup items

• /Library/StartupItems

• /System/Library/StartupItems

Only kept for Legacy purposes. Use not recommended.



4.3 Hierarchy

• User

• Local

• Network

• System

When the OS wants a resource it will look for it in the following order. Network is only if 
you’re bound to a central directory like OD or AD.



4.4 Resource and Data 
Fork

file.doc ._file.doc ._file.doc

file.doc file.doc

Mac (HFS+) FAT32 thumbdrive PC (NTFS)

When you copy a Mac file into a FAT32 thumbdrive, it will split into resource and data forks. 
Resource fork will add ._ to the file name. When opening the file on a Windows machine, just 
need to open the data fork. 



4.5 Hidden items

• Use a . in the filename (eg .mysecret)

• chflags file property

• use Terminal to view hidden files (ls -la)

To hide a file on the Mac, use . in the filename or change the chflags property. You can only 
do this using the command line in Terminal. You can also use Terminal to view hidden files.



4.6 Launch Services 
settings

If you want a specific program to open files, right click on a file and choose Get Info. Choose 
Open With and set the specific program there. Click Change all to make all files of that type 
open in that specific program.



4.7 Quicklook

To preview any file, click it and press the space bar to preview.



4.8 Spotlight



To search for any file, press Command-Space and type in what you wish to find.



You can disable the various plugins to limit the search results.



Use the privacy tab to prevent Spotlight from searching that location.



4.9 ZIP archive



You can compress files using Zip compression. Open Macintosh HD -> Library.



Click Desktop Pictures.



Right click Desktop Pictures and choose Copy.



Right click your Desktop and choose Paste.



Right click the Desktop Pictures on your Desktop.



Choose Compress.



A zip file will be created.



4.10 Disk Images



You can also create Disk Images using Disk Utility. Search for Disk Utility.



In Disk Utility choose File -> New -> Disk Image from Folder...



Choose a folder and click Image.



Set encryption. Change the name of the image. Click Save.



Put in the password when requested. Don’t tick Remember password in my keychain.



Here you can see the image on your desktop. Double click it.



Key in the password. Click OK.



The contents of the image are displayed.



If you don’t want to use the image any more, eject it.



4.11 Time Machine



It is best to use Time Machine with an external disk, but for the purpose of demonstration we 
will just back up to the Backup volume we created earlier on the thumbdrive.
Go to System Preferences -> Time Machine. Click Select Backup Disk...
WARNING: Do not partition your internal hard disk if you have Boot Camp installed as this will 
disable Boot Camp.



Click Backup. Click Use Disk.



Time Machine on and choose Options.



To save time, we’re going to exclude some things from the backup. Click +. It is 
recommended that you do NOT exclude the items if you’re doing this for real.



Choose Macintosh HD from the pop up menu and select Application, Library and System. 
Click Exclude.



Click Exclude All System Files.



Click Save.



To recover items, choose Enter Time Machine from the Time Machine menu.



Use the arrows to go back in time. Click Restore to recover the item.



5. Application and Boot 
Camp



5.1 Installation



There are three ways to get Mac programs. The first way is the App Store. Choose App 
Store... from the Apple menu.



We’re going to look for an app that expands .rar files.



Type ‘the unarchiver’ in the search box.



Click on the install button on the The Unarchiver pane.



If you have an AppleID, enter it here. Otherwise click Create Apple ID.



Click Continue.



Tick ‘I have read and agree to these terms and conditions’. Click Agree.



Enter the details to create your AppleID. At the end of this process, you’ll be able to 
download all the free apps from the App Store.



You can also download Apps from The Free Mac classroom (thefreemac.com). Some apps 
have drag and drop install, others will use Installer.



Skype is an example of a drag and drop install. Download Skype from www.skype.com.



The download will appear in your Downloads folder. Double click it to launch.



Just drag Skype into the Applications folder shortcut as shown. It will be copied into the 
Applications folder. Remember to eject the disk image when done.



Windows Media Components for QuickTime allows you to play Windows Media content on 
your Mac. Download it from www.microsoft.com.



Double click on the disk image to open it.



Double click Flip4Mac.pkg to launch the Apple Installer.



Just follow the step by step installation by clicking Continue.



Enter the administrator username and password when prompted.



The program has been installed. Click Close.



5.2 Delete Applications

To delete applications, just put it into the Trash and choose Empty Trash.



5.3 Force Quit

If programs hang, you can Force Quit them by pressing Command-Option-Esc.



5.4 Activity Monitor

If your Mac feels slow, you can open Activitiy Monitor to see which programs are taking up a 
lot of resources.



5.5 Accessibility



You can change the cursor size to make it easier to see.



You can also zoom in and out to make items on your screen easier to see.



5.6 Application 
troubleshooting



If a file won’t open, try opening in another program. Right click the file and choose Open 
With...



Try removing the Preferences of the program you are using. The computer will create a fresh 
copy.



Try removing any additional fonts in your system.



Finally, you can try removing everything in the ~/Library/Caches and /Library/Caches folder.



5.7 Dashboard



To access Dashboard, press F4 on the keyboard.



You can make web content appear in Dashboard. Go to a website which has the elements you 
want. 



Choose File -> Open in Dashboard...



Choose the area of the screen that you would like to appear in Dashboard. Click Add.



It appears in the Dashboard.



5.8 Windows



Boot Camp

To run Windows on your Mac, use Boot Camp. It comes with every Mac. You will need a full 
Windows software and license as well.



VirtualBox

You can also install VirtualBox which is a free download from www.virtualbox.org.



6. Network 
configuration



6.1 Location



You can set up multiple locations for one computer. Each location can be configured 
differently. Open System Preferences -> Network.



Choose Edit Locations... from the location menu.



Click the + button to create a new location. Click Done. Click Apply.



Now you can switch locations using the Apple menu -> Location.



6.2 Ethernet settings

To configure your Ethernet connection, click on Ethernet on the left hand pane. Click 
Advanced.



6.3 Wi-Fi settings

To configure Wi-Fi settings, click on Wi-Fi on the left hand pane. Click Advanced.



6.4 Advanced



Wi-Fi (Wi-Fi only) - Allows you to set preferred Networks, remember previous networks 
joined, and administrator control.



TCP-IP - allows you to set either DHCP or fixed IP.



DNS - allows you to set DNS servers.



WINS - allows you to set Workgroup and WINS servers.



802.1x - If your network has 802.1x connection, the configuration will be automatic and will 
appear here.



Proxies - Allows you to set the Proxy server.



Hardware - allows you to set the hardware characteristics of the port.



6.5 Network 
Diagnostics



If your network connection isn’t working properly you can click Assist me... in the System 
Preferences -> Network pane. Click Diagnostics.



The wizard walks you through the troubleshooting process.



6.6 Network Utility

You can use the Network Utility to perform common network troubleshooting tasks such as 
Ping and Lookup.



7. Network services



7.1 Network 
Neighborhood



Choose Network from the Finder’s Go menu.



You will see all the computers in the local area network.



7.2 File sharing



On computer A, open System Preferences and choose Sharing. You can change the computer 
name here.



Tick File Sharing.



Under options, you can enable Mac File sharing only or both Mac and Windows file sharing. 
For Windows file sharing, you also have to enable the specific accounts.



On computer B, choose Network from the Finder’s go menu. Computer A should be visible. 
Double-click it.



Click Connect As...



Put in admin’s username and password.



Computer A’s shared files appear.



7.3 Screen Sharing



On computer A, turn on Screen Sharing. Click the Computer Settings button.



You can set it so anyone can control your screen, and so VNC viewers can control the screen 
with a password.



On computer B, choose Network from the Finder’s go menu. Computer A should be visible. 
Double-click it.



Click on Share Screen.



Put in admin’s username and password. Click Connect.



You can see computer A’s screen on your screen.



Another way to control a computer over the network is by using Messages. Launch Messages. 
Click Not Now.



Click Skip.



Click Not Now.



Messages main window appears.



Choose Bonjour from Messages -> Accounts menu. This will autodetect computers on the 
same subnet as you.



Choose Buddies from the Window menu to display all the computers on the same subnet as 
you.



Here you can see a computer B appear on Computer A’s buddies list.



You can choose to share your screen, or ask to share Computer B’s screen.



You will see this message on your computer.



Computer B will see this message. Click it.



On computer B, click Accept.



Screen sharing starts. If you are asking to share computer B’s screen, your own screen will 
appear on the lower right hand corner.



7.5 Remote Login



Turn on Remote Login on Computer A.



On Computer B, type in the commands as shown.



Computer A responds to Computer B’s commands.



7.5 Firewall



To protect your computer from attacks over the network, you can turn on your firewall.



Click the lock and enter the admin username and password. Click Advanced.



Here you can see the advanced settings.



7.6 Port scanning



You can check which ports are open on a computer by using Network Utility Port Scan. On 
computer B, enter Computer A’s address.



You can see which ports are open.



8. Peripherals & Printing



8.1 Buses

USB3 - USB peripherals such as mouse, keyboard, thumbdrive
Bluetooth - Wireless devices
Thunderbolt - High speed peripherals, Target disk mode



8.2 Classes

HID - Human Input devices such as mouse and keyboard
Storage - thumbdrives and hard disks



8.3 Driver

• Extensions

• Plugins

• Applications

Extensions - /System/Library/Extensions and /Library/Extensions
Plugins - for scanners and cameras
Applications - iTunes is the driver for iOS devices



8.4 System Information



Choose About This Mac from the Apple menu



Click More Info...



Click System Report...



Here is all the hardware information.



8.5 Troubleshooting

• Check System Information

• Check for updated drivers

• Check physical device



8.5 Printing



Open System Preferences.



Click on the + sign.



Any USB printers directly connected to the Mac, and any printers using Bonjour can be seen 
here.



You can also add Local Network Printer by manually putting in the information. Use the PCL 
driver if no native driver is detected.



Click Skip.



Click OK.



Your printer has been setup. Click Open Print Queue to see print jobs. Click Options & 
Supplies to change driver, set printer information and to check supply levels.



If you have a printer shared by a Windows computer you can connect to it here.



Open a document to be printed, for example, the About Stacks file in the Documents folder in 
your home directory.



Choose Print from the File menu.



Click on Show Details.



You can change your print settings here before you start printing. Click Print.



Print queue appears in the Dock.



Here we see the current print job. Click x to cancel.



You can share a printer to other Macs using the Sharing system preference.



You can right-click in the printer window to reset the printing system to factory defaults.



9. Startup Process



Stages

• Firmware

• Booter

• Kernel

• System launchd

• loginwindow

• User launchd

Firmware - you hear a chime, hardware test done
Booter - gray Apple logo, loads kernel
Kernel - rotating gear wheel, loads iokit and extensions
System launchd - starts launchdemons and loginwindow
loginwindow - user authentication
User launchd - starts launchagents



Modifiers

• Option

• T

• Shift (safe mode)

• Command-S (single user mode)

Option - choose which disk to start up from
T - target disk mode
Shift - special mode that loads minimum set of extensions
Command-S - low level mode, user is root



Safe mode

• fsck

• /System/Library/Extensions

• /System Library/LaunchDemons

• Automatic login disabled

• /System/Library/LaunchAgents

• login items disabled

What safe mode does



10. Hardware
(refer to the user 

manual)


